Re: [oom][sdnc] Just deploy sdnc?


Michael O'Brien <frank.obrien@...>
 

Forgot a point about the onap namespace that applies to everyone.

 

Namespace=onap

 

If you are not deploying more than one deployment of onap (2 sdnc’s for example) – name the namespace onap – as I understand there are still a couple instances of expecting a hardcoded onap namespace.

I understand there is a jira on allowing for more than 1 deployment of onap per kubernetes cluster that will fix this – I just cannot find it.

 

Use “onap” and you will reduce one more wildcard when triaging any failed pods

 

 

 

From: onap-discuss@... <onap-discuss@...> On Behalf Of Michael O'Brien
Sent: Thursday, January 10, 2019 4:09 PM
To: onap-discuss@...; serverascode@...
Subject: Re: [onap-discuss] [oom][sdnc] Just deploy sdnc?

 

Curtis,

   Hello fellow onap deployment enthusiast.

   Your question is very relevant for developer environments and limited memory VM’s like a dev kubernetes cluster running on a laptop.

   I am trying to keep track of issues I also run into here.

   https://wiki.onap.org/display/DW/ONAP+Development#ONAPDevelopment-DeveloperDeployment

 

   Ideally – each onap pod in the values.yaml can be deployed independently – in general I have seen this – there are the odd non-atomic check between pods like sdc to dmaap for their hc.

   In general for runtime at least you will see issues with dependent microservices – streaming logs from the filebeat sidecar will fail for example if log-logstash is not up – however 2/2 and 3/3 pods including a filebeat container are not blocked by runtime – and will start fine.

    In your case the sdnc-0 filebeat is not working because the emptydir pv is likely not up yet between the 2 pods.

   You can consult one possible hierarchy of deployment in the review https://gerrit.onap.org/r/#/c/75422/

 

   For your init failures like dmaap – I would expect they should not be blocked by no dmaap pods – but I usually run with at least the base pods aaf,dmaap and aai if I run any other pod like sdnc, appd, sdc, so etc…

    Is there a reason you are not running with some minimal subset – in one of my development cases I run with just robot and aai or robot and log/pomba/dmaap – however I did not exercise all the functionality to verify this scenario was fully functional.

    /michael

 

3.0.0-ONAP Casablanca tag from yesterday

onap onap-sdnc-nengdb-0 1/1 Running 0 5h

onap onap-sdnc-network-name-gen-7f95f5bfc8-92jdx 1/1 Running 0 5h

onap onap-sdnc-sdnc-0 2/2 Running 0 5h

onap onap-sdnc-sdnc-ansible-server-7d595dd8-rp5rc 1/1 Running 0 5h

onap onap-sdnc-sdnc-db-0 2/2 Running 0 5h

onap onap-sdnc-sdnc-dgbuilder-7c8fcbff77-9drhc 1/1 Running 0 5h

onap onap-sdnc-sdnc-dmaap-listener-fd8bf55cf-qqqwz 1/1 Running 0 5h

onap onap-sdnc-sdnc-portal-55976f4bd-qpd6x 1/1 Running 0 5h

onap onap-sdnc-sdnc-ueb-listener-7bf689f8b9-q2p4x 1/1 Running 0 5h

 

 

A rule of thumb – if you don’t see the pod up within an hour – it will likely not come up  - this is a timeout limitation of kubernetes jobs – that is being fixed by moving to helm hooks in Dublin – in that case restart your pod – flip the enabled flag – however an important point – delete the /dockerdata-nfs/onap-<pod> dir – as some pods will not rerun their config job if the directory is populated.

 

Also note the deletion cleanup steps – also for rogue pods

https://wiki.onap.org/display/DW/ONAP+Development#ONAPDevelopment-RemoveaDeployment

 

do a describe on your failed pod to get info – it looks like sdnc-0 is waiting on the dmaap and ueb listeners – check requirements.yaml hierarchy to be sure.

casablanca-sdnc-0                                  1/2     CrashLoopBackOff   46         3h31m

 

From: onap-discuss@

lists.onap.org <onap-discuss@...> On Behalf Of Curtis
Sent: Wednesday, January 9, 2019 5:55 PM
To: onap-discuss@...
Subject: [onap-discuss] [oom][sdnc] Just deploy sdnc?

 

Hi,

 

I'd just like to deploy sdnc if possible. I have turned off everything in the onap/values.yml file except sdnc. It seems to have deployed, I can access the portal, but there are a few pods which seem unnecessary, though I'm not completely sure--am new to sdnc.  (For sdnc-0 filebeat is not working.) dmaap listening and ueb listening are waiting for the check script to find message-router and sdc-be.

 

If anyone has any recommendations or concerns around just deploying sdn-c, let me know. :) Otherwise will continue working through it. I just thought I'd mention this.

 

Current pods:

 

$ k get pods -n onap
NAME                                               READY   STATUS             RESTARTS   AGE
casablanca-controller-blueprints-84dfd855b-phplq   1/1     Running            0          4h19m
casablanca-controller-blueprints-db-0              1/1     Running            0          4h19m
casablanca-nengdb-0                                1/1     Running            0          4h19m
casablanca-network-name-gen-5d4847f747-th2t2       1/1     Running            0          4h19m
casablanca-sdnc-0                                  1/2     CrashLoopBackOff   46         3h31m
casablanca-sdnc-ansible-server-5c9bb57797-tvf7x    1/1     Running            0          4h19m
casablanca-sdnc-db-0                               2/2     Running            0          4h19m
casablanca-sdnc-dgbuilder-75b88dd7cd-xfjcm         1/1     Running            0          4h19m
casablanca-sdnc-dmaap-listener-9d4f55c64-s94sc     0/1     Init:0/1           1          4h19m
casablanca-sdnc-portal-597966f975-bnvrd            1/1     Running            0          4h19m
casablanca-sdnc-ueb-listener-79c9cc6fb6-hnvnj      0/1     Init:0/1           0          4h19m

 

Thanks kindly,

Curtis

This email and the information contained herein is proprietary and confidential and subject to the Amdocs Email Terms of Service, which you may review at https://www.amdocs.com/about/email-terms-of-service

This email and the information contained herein is proprietary and confidential and subject to the Amdocs Email Terms of Service, which you may review at https://www.amdocs.com/about/email-terms-of-service

Join onap-discuss@lists.onap.org to automatically receive all group messages.