Re: [AAI] [portal] Not able to access AAI GUI from ONAP Portal - Latest master (El Alto)

Manoop Talasila
 

Hi Thiriloshini,

 

If you have not figured out yet, please try below suggestion.

 

If AAI app is running healthy, you may try to read last comments in https://jira.onap.org/browse/PORTAL-653 to follow steps to access A&AI from Portal GUI. Thanks.

 

Manoop

 

From: <onap-discuss@...> on behalf of "Thiriloshini.ThoppeKrishnakumar@..." <thiriloshini.thoppekrishnakumar@...>
Reply-To: "onap-discuss@..." <onap-discuss@...>, "thiriloshini.thoppekrishnakumar@..." <thiriloshini.thoppekrishnakumar@...>
Date: Friday, October 18, 2019 at 5:09 PM
To: "onap-discuss@..." <onap-discuss@...>
Cc: "Xin.Miao@..." <Xin.Miao@...>, Thamlur Raju <TR00568434@...>, Aniello Paolo Malinconico <a.malinconico@...>
Subject: [onap-discuss][AAI] [portal] Not able to access AAI GUI from ONAP Portal - Latest master (El Alto)

 

Hi,

 

I have an ONAP Cluster deployed using OOM on latest master (El-Alto)

 

  1. The AAI containers are up and running

ubuntu@onap-rancher-vm:~$ kubectl get po -n onap -o wide | grep aai

dev-aai-aai-66c5dbb669-jbqmm                            1/1     Running            1          22h   10.42.1.131   onap-k8s-vm-1   <none>           <none>

dev-aai-aai-babel-6c74f9f776-bh7n7                      2/2     Running            2          45h   10.42.2.87    onap-k8s-vm-2   <none>           <none>

dev-aai-aai-data-router-76dfd7f4bb-zbr5g                2/2     Running            2          45h   10.42.2.96    onap-k8s-vm-2   <none>           <none>

dev-aai-aai-elasticsearch-665b4859c8-btmk9              1/1     Running            1          45h   10.42.2.91    onap-k8s-vm-2   <none>           <none>

dev-aai-aai-graphadmin-6d4b8fccc4-bk2mj                 2/2     Running            2          45h   10.42.1.111   onap-k8s-vm-1   <none>           <none>

dev-aai-aai-graphadmin-create-db-schema-vldhz           0/1     Completed          0          45h   10.42.2.14    onap-k8s-vm-2   <none>           <none>

dev-aai-aai-graphgraph-7645ff8687-g5f56                 1/1     Running            1          45h   10.42.2.95    onap-k8s-vm-2   <none>           <none>

dev-aai-aai-modelloader-6dffb4788f-c9wfs                2/2     Running            2          45h   10.42.1.118   onap-k8s-vm-1   <none>           <none>

dev-aai-aai-resources-57f96dfbd6-59m8w                  2/2     Running            2          45h   10.42.2.93    onap-k8s-vm-2   <none>           <none>

dev-aai-aai-schema-service-595f644b5-n6bv5              2/2     Running            2          45h   10.42.2.82    onap-k8s-vm-2   <none>           <none>

dev-aai-aai-search-data-9c5bcc994-rh8kg                 2/2     Running            2          45h   10.42.2.85    onap-k8s-vm-2   <none>           <none>

dev-aai-aai-sparky-be-5fc6985fb6-zqvnb                  2/2     Running            2          45h   10.42.2.92    onap-k8s-vm-2   <none>           <none>

dev-aai-aai-traversal-76788cbfdc-mgsj6                  2/2     Running            2          45h   10.42.2.86    onap-k8s-vm-2   <none>           <none>

dev-aai-aai-traversal-update-query-data-xrhh7           0/1     Completed          0          45h   10.42.1.16    onap-k8s-vm-1   <none>           <none>

ubuntu@onap-rancher-vm:~$

ubuntu@onap-rancher-vm:~$ kubectl get services -n onap -o wide | grep aai

aai                        NodePort       10.43.166.80    <none>            8443:30233/TCP                                                45h   app=aai

aai-babel                  NodePort       10.43.212.34    <none>            9516:30279/TCP                                                45h   app=aai-babel,release=dev-aai

aai-elasticsearch          ClusterIP      None            <none>            9200/TCP,8443/TCP                                             45h   app=aai-elasticsearch,release=dev-aai

aai-graphadmin             ClusterIP      None            <none>            8449/TCP,5005/TCP                                             45h   app=aai-graphadmin,release=dev-aai

aai-graphgraph             ClusterIP      10.43.9.26      <none>            8453/TCP                                                      45h   app=aai-graphgraph,release=dev-aai

aai-modelloader            NodePort       10.43.46.140    <none>            8080:30210/TCP,8443:30229/TCP                                 45h   app=aai-modelloader,release=dev-aai

aai-resources              ClusterIP      None            <none>            8447/TCP,5005/TCP                                             45h   app=aai-resources,release=dev-aai

aai-schema-service         ClusterIP      None            <none>            8452/TCP,5005/TCP                                             45h   app=aai-schema-service,release=dev-aai

aai-search-data            ClusterIP      None            <none>            9509/TCP                                                      45h   app=aai-search-data,release=dev-aai

aai-sparky-be              NodePort       10.43.183.209   <none>            8000:30220/TCP                                                45h   app=aai-sparky-be,release=dev-aai

aai-traversal              ClusterIP      None            <none>            8446/TCP,5005/TCP                                             45h   app=aai-traversal,release=dev-aai

  1. Please find the portal-app service below

ubuntu@onap-rancher-vm:~$ kubectl get services -n onap -o wide | grep portal

portal-app                 LoadBalancer   10.43.36.76     167.254.204.109   8989:30215/TCP,8006:30213/TCP,8010:30214/TCP,8443:30225/TCP   25h   app=portal-app,release=dev-portal

  1. I have my /etc/hosts updated with the below data

 

167.254.204.109 portal.api.simpledemo.onap.org

167.254.204.109 vid.api.simpledemo.onap.org

167.254.204.109 sdc.api.fe.simpledemo.onap.org

167.254.204.109 portal-sdk.simpledemo.onap.org

167.254.204.109 policy.api.simpledemo.onap.org

167.254.204.109 aai.ui.simpledemo.onap.org

167.254.204.109 cli.api.simpledemo.onap.org

167.254.204.109 msb.api.discovery.simpledemo.onap.org

167.254.204.109 portal-app.onap

167.254.204.109 so-monitoring

  1. I logged in to the portal using the username jh0003 (admin). I’m able to login to SDC without any issue. I don’t see the AAI in ONAP Portal.
  2. Followed the link and added the role to user_id (jh0003)

 

Insert into fn_role (ROLE_ID,ROLE_NAME,ACTIVE_YN,PRIORITY,APP_ID,APP_ROLE_ID) values (2144,'ui_view','Y', NULL, 7,2144);
Insert into fn_user_role (USER_ID,ROLE_ID,PRIORITY,APP_ID) values (2,2144,null,7);

 

Please find the available users for reference

 

MariaDB [portal]> SELECT USER_ID, login_id, first_name, org_user_id, email FROM fn_user;

+---------+----------+------------+-------------+-------------------+

| USER_ID | login_id | first_name | org_user_id | email             |

+---------+----------+------------+-------------+-------------------+

|       2 | jh0003   | Jimmy      | jh0003      | admin@...    |

|       3 | cs0008   | Carlos     | cs0008      | designer@... |

|       4 | jm0007   | Joni       | jm0007      | tester@...   |

|       5 | op0001   | Steve      | op0001      | ops@...      |

|       6 | gv0001   | David      | gv0001      | governor@... |

|       7 | pm0001   | Teddy      | pm0001      | pm1@...      |

|       8 | ps0001   | Eden       | ps0001      | ps1@...      |

|       9 | vid1     | vid1       | vid1        | vid1@...     |

|      10 | vid2     | vid2       | vid2        | vid2@...     |

|      11 | vid3     | vid3       | vid3        | vid3@...     |

|      12 | steve    | steve      | steve       | steve@...    |

+---------+----------+------------+-------------+-------------------+

 

  1. After the above step, I see AAI in the ONAP Portal

 

 

  1. When I click on AAI, it says portal.api.simpledemo.onap.org refused to connect.

 

 

  1. When I try to open AAI in a separate tab using http://aai.ui.simpledemo.onap.org:30220/services/aai/webapp/index.html, it returns ERR_INVALID_HTTP_RESPONSE. Using https instead of http http://aai.ui.simpledemo.onap.org:30220/services/aai/webapp/index.html, redirects to ONAP Portal page.

 

Any input is highly appreciated.

Please let me know if more information is needed.

 

Thanks,

Thiriloshini

Join onap-discuss@lists.onap.org to automatically receive all group messages.