Re: Dublin CLAMP vFWCL scenario #clamp #dcaegen2 #policy #dublin #controlloop


Gao, Xue
 

Hello Andrzej,

 

It seems there’s something wrong with the micro service values, which causes the NullPointerException and due to that, of course, all the Submit and Deployment was not working as expected.

 

Could you please access to the Clamp DB and check the value of policy_tosca column from micro_Service_policies table of your loop and send me back the result?

 

 

Thanks!

 

Kr,

 

Xue

 

From: onap-discuss@... <onap-discuss@...> On Behalf Of andrzej.denisiewicz via Lists.Onap.Org
Sent: Monday, December 2, 2019 12:50 PM
To: onap-discuss@...
Subject: [onap-discuss] Dublin CLAMP vFWCL scenario #clamp #dublin #controlloop #policy #dcaegen2

 

Hi,

Anybody manage run vFWCL scenario using CLAMP GUI?

I have the following problems:

Trying submit I get:
 

2019-11-29T14:40:48Z

INFO

tca_k8s_ad_vFWCL_v1_0_ad_sp_pg0_k8s-tca-policy creation status - 404 : Not Found

2019-11-29T14:40:47Z

INFO

tca_k8s_ad_vFWCL_v1_0_ad_sp_pg0_k8s-tca-policy removal status - 404 : Not Found

2019-11-29T14:40:46Z

INFO

tca_k8s_ad_vFWCL_v1_0_ad_sp_pg0_k8s-tca-policy PDP Group removal status - 404 : Not Found

2019-11-29T14:40:46Z

INFO

OPERATIONAL_ad_vFWCL_v1_0_ad_sp_pg0_k8s-tca-policy PDP Group removal status - 404 : Not Found

2019-11-29T14:40:45Z

INFO

POLICY SUBMIT request


In clamp container log I see:

org.apache.camel.language.bean.RuntimeBeanExpressionException: Failed to invoke method: createPolicyPayload() on null due to: java.lang.NullPointerException
...
Caused by: java.lang.NullPointerException: null
        at org.onap.clamp.policy.microservice.MicroServicePolicy.getMicroServicePropertyNameFromTosca(MicroServicePolicy.java:247)
        at org.onap.clamp.policy.microservice.MicroServicePolicy.createPolicyPayload(MicroServicePolicy.java:279)

Next I try to ignore this error and deploy:

2019-12-02T10:25:00Z

INFO

DEPLOY request successfully executed

2019-12-02T10:25:00Z

INFO

DEPLOY loop status (id:CLAMP_92452f68-471b-4dfb-8799-33beb4283236) - 202 : Accepted

2019-12-02T10:24:22Z

INFO

Global Properties UPDATED

2019-12-02T10:24:18Z

ERROR

POLICY status IN_ERROR/DCAE status NOT_DEPLOYED, DCAE deployment will be started anyway

2019-12-02T10:24:18Z

INFO

Policy deployment status - 400 : Bad Request

2019-12-02T10:24:18Z

INFO

DCAE DEPLOY request



And in clamp container log I see:

10:24:17.106 [https-jsse-nio-8443-exec-7] INFO  route8 - DCAE DEPLOY request for loop: LOOP_ad_vFWCL_v1_0_ad_sp_pg0_k8s-tca-policy
10:24:17.114 [https-jsse-nio-8443-exec-7] INFO  org.onap.clamp.flow.log.FlowLogOperation - ENTRY
10:24:18.409 [https-jsse-nio-8443-exec-7] INFO  get-status-from-policy - Query Closed Loop status from policy PDP: LOOP_ad_vFWCL_v1_0_ad_sp_pg0_k8s-tca-policy
10:24:18.423 [https-jsse-nio-8443-exec-7] INFO  org.onap.clamp.flow.log.FlowLogOperation - INVOKE
10:24:18.423 [https-jsse-nio-8443-exec-7] INFO  org.onap.clamp.flow.log.FlowLogOperation - INVOKE-SYNCHRONOUS{ccb34448-7967-4377-baf9-00eb07c1cdb5}
10:24:18.425 [https-jsse-nio-8443-exec-7] INFO  get-status-from-policy - Endpoint to query from Policy PDP: https4://policy-api.onap:6969/policy/api/v1/policytypes/onap.policies.controlloop.Operational/versions/1.0.0/policies/OPERATIONAL_ad_vFWCL_v1_0_ad_sp_pg0_k8s-tca-policy/versions/deployed
10:24:18.479 [https-jsse-nio-8443-exec-7] INFO  org.apache.camel.component.http4.HttpComponent - Created ClientConnectionManager org.apache.http.impl.conn.PoolingHttpClientConnectionManager@22be5e8a
10:24:18.668 [https-jsse-nio-8443-exec-7] INFO  org.onap.clamp.flow.log.FlowLogOperation - INVOKE-RETURN
10:24:18.671 [https-jsse-nio-8443-exec-7] INFO  dump-loop-log-http-response - Policy deployment status - 400 : Bad Request
10:24:18.773 [https-jsse-nio-8443-exec-7] INFO  get-status-from-dcae - Query Closed Loop status from DCAE LOOP_ad_vFWCL_v1_0_ad_sp_pg0_k8s-tca-policy
10:24:18.777 [https-jsse-nio-8443-exec-7] INFO  get-status-from-dcae - dcae status: NOT_DEPLOYED
10:24:18.777 [https-jsse-nio-8443-exec-7] INFO  route8 - Policy deployment status: IN_ERROR
10:24:18.786 [https-jsse-nio-8443-exec-7] INFO  route8 - POLICY status IN_ERROR/DCAE status NOT_DEPLOYED, DCAE deployment will be started anyway
10:24:18.832 [https-jsse-nio-8443-exec-7] INFO  deploy-loop - Deploying the loop: LOOP_ad_vFWCL_v1_0_ad_sp_pg0_k8s-tca-policy
10:24:18.842 [https-jsse-nio-8443-exec-7] INFO  org.onap.clamp.flow.log.FlowLogOperation - INVOKE
10:24:18.842 [https-jsse-nio-8443-exec-7] INFO  org.onap.clamp.flow.log.FlowLogOperation - INVOKE-SYNCHRONOUS{d4c47ba7-1872-4d9b-8b8a-86adc3122407}
10:24:18.843 [https-jsse-nio-8443-exec-7] INFO  org.onap.clamp.loop.LoopOperation - Dcae api Body String - {"serviceTypeId":"e0aabbbb-fc62-44d6-ad3f-95037b6066c6","inputs":{"aaiEnrichmentHost":"aai.onap.svc.cluster.local","aaiEnrichmentPort":"8443","enableAAIEnrichment":true,"dmaap_host":"message-router.onap.svc.cluster.local","dmaap_port":"3904","enableRedisCaching":false,"redisHosts":"dcae-redis.onap.svc.cluster.local:6379","tag_version":"nexus3.onap.org:10001/onap/org.onap.dcaegen2.deployments.tca-cdap-container:1.0.0","consul_host":"consul-server.onap.svc.cluster.local","consul_port":"8500","cbs_host":"config-binding-service.dcae.svc.cluster.local","cbs_port":"10000","external_port":"32010","policy_id":"tca_k8s_ad_vFWCL_v1_0_ad_sp_pg0_k8s-tca-policy"}}
10:24:18.845 [https-jsse-nio-8443-exec-7] INFO  deploy-loop - Endpoint to deploy loop: https4://deployment-handler.onap:8443/dcae-deployments/CLAMP_92452f68-471b-4dfb-8799-33beb4283236
10:24:18.866 [https-jsse-nio-8443-exec-7] INFO  org.apache.camel.component.http4.HttpComponent - Created ClientConnectionManager org.apache.http.impl.conn.PoolingHttpClientConnectionManager@3468cd53

Also I see created pod in a strange state:

dep-s21ee030a973d4b569611df7b5f710448-dcaegen2-analytics-t27tj2   1/2     ImagePullBackOff   0          18m

I appreciate any suggestion
Thanks
Andrzej

Join onap-discuss@lists.onap.org to automatically receive all group messages.