[integration] Testing is blocked by VID, now is 6:54 AM, 10/4/2017, PDT


Helen Chen
 

Hi, Ofir & Amichai,

Is it possible for you to share your other quicker contact with me? Such as WeChat or Whatsapp. It looks like we need your help  a lot in recent few days.

 

Regards,

 

Helen Chen

 

From: Subhash Kumar Singh <subhash.kumar.singh@...>
Date: Wednesday, October 4, 2017 at 6:48 AM
To: Kranthi Guttikonda <kranthi.guttikonda@...>, "KAJUR, HARISH V" <vk250x@...>, "SONSINO, OFIR" <os0695@...>, Helen Chen 00725961 <Helen.Chen@...>, onap-discuss <onap-discuss@...>, "HEMLI, AMICHAI" <ah0398@...>
Cc: Kanagaraj Manickam <kanagaraj.manickam@...>
Subject: RE: [onap-discuss] [integration] Integration testing results for 10/3/2017

 

Hello Everyone,

 

I am facing issue in bringing up the VID.

Today, I tried to bring-up the ONAP stack using latest heat template, but VID is not accessible from portal.

 

It looks like “VID-server” is not able to collect response from “VID-mariadb”. Following are the docker logs:

VID-server : http://paste.openstack.org/show/622658/

VID-mariadb: http://paste.openstack.org/show/622660/

 

At the same time, VID is passing health test from robot test case(ete.sh health).

 

Please let me know to fix this issue.

 

--

Regards,

Subhash Kumar Singh

 

***************************************************************************************
邮件及其附件含有华为公司的保密信息,仅限于发送给上面地址中列出的个人或群组。禁止任何其他人以任何形式使用(包括但不限于全部或部分地泄露、复制、或散发)本邮件中的信息。如果您错收了本邮件,请您立即电话或邮件通知发件人并删除本邮件!**************************************************************************************

***************************************************************************************
This e-mail and its attachments contain confidential information from HUAWEI, which is intended only for the person  or entity whoseaddress is listed above. Any use of the information contained herein in any way (including, but not  
 limited to, total or partial disclosure,reproduction, or dissemination) by persons other than the intended recipient(s) is  prohibited. If you receive this e-mail in error, pleasenotify the sender by phone or email immediately and delete it!
***************************************************************************************

 

From: onap-discuss-bounces@... [mailto:onap-discuss-bounces@...] On Behalf Of Kranthi Guttikonda
Sent: Wednesday, October 04, 2017 7:02 PM
To: KAJUR, HARISH V <vk250x@...>; SONSINO, OFIR <os0695@...>; Yunxia Chen <Helen.Chen@...>; onap-discuss <onap-discuss@...>; HEMLI, AMICHAI <ah0398@...>
Subject: Re: [onap-discuss] [integration] Integration testing results for 10/3/2017

 

Great. It works. Thanks Harish

 

Kranthi

 

From: "KAJUR, HARISH V" <vk250x@...>
Date: Wednesday, October 4, 2017 at 9:12 AM
To: Kranthi Guttikonda <kranthi.guttikonda@...>, "SONSINO, OFIR" <os0695@...>, Yunxia Chen <Helen.Chen@...>, onap-discuss <onap-discuss@...>, "HEMLI, AMICHAI" <ah0398@...>
Subject: RE: [onap-discuss] [integration] Integration testing results for 10/3/2017

 

Hi Kranthi,

 

You are missing the X-TransactionId header from your curl request.

If you provide that value, it should work properly.

 

Thanks,

Harish

 

From: Kranthi Guttikonda [mailto:kranthi.guttikonda@...]
Sent: Wednesday, October 04, 2017 7:57 AM
To: SONSINO, OFIR <os0695@...>; Yunxia Chen <Helen.Chen@...>; onap-discuss <onap-discuss@...>; HEMLI, AMICHAI <ah0398@...>; KAJUR, HARISH V <vk250x@...>
Subject: Re: [onap-discuss] [integration] Integration testing results for 10/3/2017

 

Hi Harish,

 

Looks like AAI is not returning data properly.

 

curl -v -u AAI:AAI -k -X GET -H 'X-FromAppId: local' -H 'Accept: application/json' -H 'Content-Type: application/json' -H 'Real-Time: true' https://10.12.25.72:8443/aai/v11/cloud-infrastructure/cloud-regions | python -m json.tool

 

In sane.log

 

04:45:55.588 [qtp1144748369-21] ERROR ajsc.filters.InterceptorFilter - Exception occurred in invokeInterceptors(...) of InterceptorFilter :

java.lang.NullPointerException: null

                at org.onap.aai.logging.LoggingContext.requestId(LoggingContext.java:119)

                at org.onap.aai.interceptors.PreAaiAjscInterceptor.allowOrReject(PreAaiAjscInterceptor.java:49)

                at ajsc.filters.InterceptorFilter.invokeInterceptors(InterceptorFilter.java:204)

                at ajsc.filters.InterceptorFilter.doFilter(InterceptorFilter.java:96)

                at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1652)

                at com.att.ajsc.csi.writeablerequestfilter.WriteableRequestFilter.doFilter(WriteableRequestFilter.java:41)

                at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1652)

                at org.eclipse.jetty.servlet.ServletHandler.doHandle(ServletHandler.java:585)

                at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:143)

                at org.eclipse.jetty.security.SecurityHandler.handle(SecurityHandler.java:542)

                at org.eclipse.jetty.server.session.SessionHandler.doHandle(SessionHandler.java:223)

                at org.eclipse.jetty.server.handler.ContextHandler.doHandle(ContextHandler.java:1127)

                at org.eclipse.jetty.servlet.ServletHandler.doScope(ServletHandler.java:515)

                at org.eclipse.jetty.server.session.SessionHandler.doScope(SessionHandler.java:185)

                at org.eclipse.jetty.server.handler.ContextHandler.doScope(ContextHandler.java:1061)

                at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:141)

                at org.eclipse.jetty.server.handler.ContextHandlerCollection.handle(ContextHandlerCollection.java:215)

                at org.eclipse.jetty.server.handler.HandlerCollection.handle(HandlerCollection.java:110)

                at org.eclipse.jetty.server.handler.HandlerWrapper.handle(HandlerWrapper.java:97)

                at org.eclipse.jetty.server.Server.handle(Server.java:497)

                at org.eclipse.jetty.server.HttpChannel.handle(HttpChannel.java:310)

                at org.eclipse.jetty.server.HttpConnection.onFillable(HttpConnection.java:257)

                at org.eclipse.jetty.io.AbstractConnection$2.run(AbstractConnection.java:540)

                at org.eclipse.jetty.util.thread.QueuedThreadPool.runJob(QueuedThreadPool.java:635)

                at org.eclipse.jetty.util.thread.QueuedThreadPool$3.run(QueuedThreadPool.java:555)

                at java.lang.Thread.run(Thread.java:748)

 

 

Thanks,
Kranthi

 

From: Kranthi Guttikonda <kranthi.guttikonda@...>
Date: Wednesday, October 4, 2017 at 7:49 AM
To: "Sonsino, Ofir" <os0695@...>, Yunxia Chen <Helen.Chen@...>, onap-discuss <onap-discuss@...>, "Hemli, Amichai" <ah0398@...>
Subject: Re: [onap-discuss] [integration] Integration testing results for 10/3/2017

 

Thanks, Ofir. Now able to see the SDC service model in VID but the deploy button is grayed out. Attached the screenshot.

 

~ Kranthi

 

From: <onap-discuss-bounces@...> on behalf of "Sonsino, Ofir" <os0695@...>
Date: Wednesday, October 4, 2017 at 6:19 AM
To: Yunxia Chen <Helen.Chen@...>, onap-discuss <onap-discuss@...>, "Hemli, Amichai" <ah0398@...>
Subject: Re: [onap-discuss] [integration] Integration testing results for 10/3/2017

 

Hi Helen,

 

I’ve just delivered a fix for VID-74.

 

Thanks,

Ofir

 

From: Yunxia Chen [mailto:Helen.Chen@...]
Sent: Wednesday, October 04, 2017 2:25 AM
To: onap-discuss <onap-discuss@...>; Sonsino, Ofir <os0695@...>; Hemli, Amichai <ah0398@...>
Subject: [integration] Integration testing results for 10/3/2017

 

1.      Installed the latest docker images from master branch today, (Will do daily update in the future starting at 6:00AM EDT)

2.      Passed all existing health check except DCAE (known issue, and have solution for it), still miss health check for the following MVP project (VFC, MSB, Multi-VIM). And jira tickets (INT-242 and its subtasks) have been created. Thanks for the help from SO, DCAE and A&AI team!

3.      Finished onboarding vFW testing.

4.      Tried to instantiate the service today, not done.

 

Identified the following issues:

1.      https://jira.onap.org/browse/AAI-411: the dependency between two AAI vms cause imtimiite issues.

2.      https://jira.onap.org/browse/VID-74: this is a block issue for Integration team tomorrow’s testing.  (Amichai Hemli / Ofir Sonsino)

 

Regards,

Helen Chen

 

Join onap-discuss@lists.onap.org to automatically receive all group messages.