Topics

APPC is not healthy install error #opendaylight-releng #appc #oom #install


jkzcristiano
 

Dear all,

I am experiencing an issue during APPC service installation. I installed ONAP Beijing before (like 3-4 times) and never had that problem. So, it is strange. I tried to change images in values.yaml to older ones but the same issue (e.g., from 1.4.0-SNAPSHOT-latest to 1.4.0-SNAPSHOT-20180901T133033Z).

Below my APPC pods:

ubuntu@rancher:~/oom/kubernetes$ kubectl get pods --all-namespaces -o=wide | grep appc
onap          onap-appc-appc-0                                                     1/2       Running   1          14m       10.42.71.236    compute2
onap          onap-appc-appc-cdt-5778bf9685-9np7j                    1/1       Running   0          14m       10.42.146.43    compute1
onap          onap-appc-appc-db-0                                                2/2       Running   0          14m       10.42.229.224   compute2
onap          onap-appc-appc-dgbuilder-75b9dc65c8-jdnqv          1/1       Running   0          14m       10.42.189.225   compute1

The "onap-appc-appc-0" pod is restarted repeatedly as time goes by.

This is the output from K8s dashboard (this error also appears here without any solution):

Readiness probe failed: APPC is not healthy. ++ ps -e ++ grep startODL ++ wc -l + startODL_status=1 ++ /opt/opendaylight/current/bin/client bundle:list ++ grep Waiting ++ wc -l Failed to get the session. + waiting_bundles=0 ++ /opt/opendaylight/current/bin/client system:start-level Failed to get the session. + run_level= + '[' '' == 'Level 100' ']' + echo APPC is not healthy. + exit 1

Can you help me, please?

Kind Regards,

Xoan


Taka Cho
 

Hi,

 

The startODL.sh initialized and took 20-30 mins now. It’s going to be enhanced for that script, but please change the time out, and let me know how it goes.

 

Taka

 

From: onap-discuss@... [mailto:onap-discuss@...] On Behalf Of jkzcristiano
Sent: Thursday, September 06, 2018 7:22 AM
To: onap-discuss@...
Subject: [onap-discuss] APPC is not healthy install error #oom #appc #install #opendaylight-releng

 

Dear all,

I am experiencing an issue during APPC service installation. I installed ONAP Beijing before (like 3-4 times) and never had that problem. So, it is strange. I tried to change images in values.yaml to older ones but the same issue (e.g., from 1.4.0-SNAPSHOT-latest to 1.4.0-SNAPSHOT-20180901T133033Z).

Below my APPC pods:

ubuntu@rancher:~/oom/kubernetes$ kubectl get pods --all-namespaces -o=wide | grep appc

onap          onap-appc-appc-0                                                     1/2       Running   1          14m       10.42.71.236    compute2

onap          onap-appc-appc-cdt-5778bf9685-9np7j                    1/1       Running   0          14m       10.42.146.43    compute1

onap          onap-appc-appc-db-0                                                2/2       Running   0          14m       10.42.229.224   compute2

onap          onap-appc-appc-dgbuilder-75b9dc65c8-jdnqv          1/1       Running   0          14m       10.42.189.225   compute1

The "onap-appc-appc-0" pod is restarted repeatedly as time goes by.

This is the output from K8s dashboard (this error also appears here without any solution):

Readiness probe failed: APPC is not healthy. ++ ps -e ++ grep startODL ++ wc -l + startODL_status=1 ++ /opt/opendaylight/current/bin/client bundle:list ++ grep Waiting ++ wc -l Failed to get the session. + waiting_bundles=0 ++ /opt/opendaylight/current/bin/client system:start-level Failed to get the session. + run_level= + '[' '' == 'Level 100' ']' + echo APPC is not healthy. + exit 1

Can you help me, please?

Kind Regards,

Xoan


jkzcristiano
 

Dear Taka Cho,

thank you very much for your answer! How can I change the time out?

Kind Regards


Aaron Hay <ah415j@...>
 

No timeout should need to be changed. The readiness state should be ready after the install completes. You can run the command below to see the installation status:

 

 

kubectl logs dev-appc-0 -c appc  -n onap  -f

 

From: onap-discuss@... <onap-discuss@...> On Behalf Of jkzcristiano
Sent: Thursday, September 06, 2018 2:05 PM
To: onap-discuss@...
Subject: Re: [onap-discuss] APPC is not healthy install error #oom #appc #install #opendaylight-releng

 

Dear Taka Cho,

thank you very much for your answer! How can I change the time out?

Kind Regards


jkzcristiano
 

Aaron, thank you for that command it helps a lot to follow what is going on.

Taka, I modified the values.yaml of appc as:

# probe configuration parameters
liveness:
  initialDelaySeconds: 100 # initially it was set to 10
  periodSeconds: 10
  # necessary to disable liveness probe when setting breakpoints
  # in debugger so K8s doesn't restart unresponsive container
  enabled: true
 
readiness:
  initialDelaySeconds: 100 # initially it was set to 10
  periodSeconds: 10


Now it worked!!! Thank you very much :)

Anayway, in case anyone experiences the same issue, just note that "during the process the error still appears but after more than 10 min. it dissapears!"

Kind Regards