#coe #coe


Samuli Silvius
 

Hi,

Building Multicloud-k8s-plugin on master fails.

Install Go 1.11
cd $GOPATH/src && git clone https://git.onap.org/multicloud/k8s
cd k8s/src/k8splugin
make build
...
go: downloading k8s.io/client-go v2.0.0-alpha.0.0.20181126152608-d082d5923d3c+incompatible
go: downloading go.etcd.io/etcd v3.3.12+incompatible
go: downloading github.com/hashicorp/consul v1.4.0
go: verifying k8s.io/client-go@....0-alpha.0.0.20181126152608-d082d5923d3c+incompatible: checksum mismatch
downloaded: h1:+gASq5lVUhelbDuyHr/ojUKGLZVeUhAFKHbAK8Kymfs=
go.sum:     h1:QOMBR2qlbwRbUJbJDXFjS8YEiXQc3AJBcEac7z3769I=
go: downloading k8s.io/client-go v2.0.0-alpha.0.0.20181126152608-d082d5923d3c+incompatible
go: downloading go.etcd.io/etcd v3.3.12+incompatible
go: downloading github.com/hashicorp/consul v1.4.0
go: finding golang.org/x/crypto/pbkdf2 latest
go: verifying k8s.io/client-go@....0-alpha.0.0.20181126152608-d082d5923d3c+incompatible: checksum mismatch
downloaded: h1:+gASq5lVUhelbDuyHr/ojUKGLZVeUhAFKHbAK8Kymfs=
go.sum:     h1:QOMBR2qlbwRbUJbJDXFjS8YEiXQc3AJBcEac7z3769I=
go: downloading k8s.io/helm v2.12.2+incompatible
go: downloading k8s.io/client-go v2.0.0-alpha.0.0.20181126152608-d082d5923d3c+incompatible
go: downloading github.com/hashicorp/consul v1.4.0
go: downloading go.etcd.io/etcd v3.3.12+incompatible
go: verifying k8s.io/helm@...+incompatible: checksum mismatch
downloaded: h1:vtddbkiGNMOd8maDDZDc111Rm9E5JeeNWDndows18i8=
go.sum:     h1:xSDfcFN8X6lfMKWQB1GmU18pnzIthU+/c7kkcl8Xlb0=
go: downloading k8s.io/client-go v2.0.0-alpha.0.0.20181126152608-d082d5923d3c+incompatible
go: downloading go.etcd.io/etcd v3.3.12+incompatible
go: downloading github.com/hashicorp/consul v1.4.0
go: verifying k8s.io/client-go@....0-alpha.0.0.20181126152608-d082d5923d3c+incompatible: checksum mismatch
downloaded: h1:+gASq5lVUhelbDuyHr/ojUKGLZVeUhAFKHbAK8Kymfs=
go.sum:     h1:QOMBR2qlbwRbUJbJDXFjS8YEiXQc3AJBcEac7z3769I=
go: downloading k8s.io/client-go v2.0.0-alpha.0.0.20181126152608-d082d5923d3c+incompatible
go: downloading go.etcd.io/etcd v3.3.12+incompatible
go: downloading github.com/hashicorp/consul v1.4.0
go: verifying k8s.io/client-go@....0-alpha.0.0.20181126152608-d082d5923d3c+incompatible: checksum mismatch
downloaded: h1:+gASq5lVUhelbDuyHr/ojUKGLZVeUhAFKHbAK8Kymfs=
go.sum:     h1:QOMBR2qlbwRbUJbJDXFjS8YEiXQc3AJBcEac7z3769I=
Makefile:31: recipe for target 'test' failed
make: *** [test] Error 1
Any idea what causes this and how to fix?

Br
-Samuli


Kiran Kamineni
 

We recently moved to Golang 1.12.4

 

-- K i r a n

 

From: onap-discuss@... [mailto:onap-discuss@...] On Behalf Of Samuli Silvius
Sent: Tuesday, May 07, 2019 11:42 PM
To: onap-discuss@...
Subject: [onap-discuss] #coe

 

Hi,

Building Multicloud-k8s-plugin on master fails.

Install Go 1.11
cd $GOPATH/src && git clone https://git.onap.org/multicloud/k8s
cd k8s/src/k8splugin
make build
...

go: downloading k8s.io/client-go v2.0.0-alpha.0.0.20181126152608-d082d5923d3c+incompatible

go: downloading go.etcd.io/etcd v3.3.12+incompatible

go: downloading github.com/hashicorp/consul v1.4.0

downloaded: h1:+gASq5lVUhelbDuyHr/ojUKGLZVeUhAFKHbAK8Kymfs=

go.sum:     h1:QOMBR2qlbwRbUJbJDXFjS8YEiXQc3AJBcEac7z3769I=

go: downloading k8s.io/client-go v2.0.0-alpha.0.0.20181126152608-d082d5923d3c+incompatible

go: downloading go.etcd.io/etcd v3.3.12+incompatible

go: downloading github.com/hashicorp/consul v1.4.0

go: finding golang.org/x/crypto/pbkdf2 latest

downloaded: h1:+gASq5lVUhelbDuyHr/ojUKGLZVeUhAFKHbAK8Kymfs=

go.sum:     h1:QOMBR2qlbwRbUJbJDXFjS8YEiXQc3AJBcEac7z3769I=

go: downloading k8s.io/helm v2.12.2+incompatible

go: downloading k8s.io/client-go v2.0.0-alpha.0.0.20181126152608-d082d5923d3c+incompatible

go: downloading github.com/hashicorp/consul v1.4.0

go: downloading go.etcd.io/etcd v3.3.12+incompatible

go: verifying k8s.io/helm@...+incompatible: checksum mismatch

downloaded: h1:vtddbkiGNMOd8maDDZDc111Rm9E5JeeNWDndows18i8=

go.sum:     h1:xSDfcFN8X6lfMKWQB1GmU18pnzIthU+/c7kkcl8Xlb0=

go: downloading k8s.io/client-go v2.0.0-alpha.0.0.20181126152608-d082d5923d3c+incompatible

go: downloading go.etcd.io/etcd v3.3.12+incompatible

go: downloading github.com/hashicorp/consul v1.4.0

downloaded: h1:+gASq5lVUhelbDuyHr/ojUKGLZVeUhAFKHbAK8Kymfs=

go.sum:     h1:QOMBR2qlbwRbUJbJDXFjS8YEiXQc3AJBcEac7z3769I=

go: downloading k8s.io/client-go v2.0.0-alpha.0.0.20181126152608-d082d5923d3c+incompatible

go: downloading go.etcd.io/etcd v3.3.12+incompatible

go: downloading github.com/hashicorp/consul v1.4.0

downloaded: h1:+gASq5lVUhelbDuyHr/ojUKGLZVeUhAFKHbAK8Kymfs=

go.sum:     h1:QOMBR2qlbwRbUJbJDXFjS8YEiXQc3AJBcEac7z3769I=

Makefile:31: recipe for target 'test' failed

make: *** [test] Error 1

Any idea what causes this and how to fix?


Br
-Samuli


Samuli Silvius
 

Hi,

 

Thanks for the info. Seems it was merged just today https://gerrit.onap.org/r/#/c/87078/ but go.mod and go.sum was merged already earlier, that’s why it was broken. And thanks for making another commit for update README https://gerrit.onap.org/r/#/c/87271/

Br

-Samuli

 

From: Kamineni, Kiran K <kiran.k.kamineni@...>
Sent: keskiviikko 8. toukokuuta 2019 21.08
To: onap-discuss@...; s.silvius@...
Subject: RE: [onap-discuss] #coe

 

We recently moved to Golang 1.12.4

 

-- K i r a n

 

From: onap-discuss@... [mailto:onap-discuss@...] On Behalf Of Samuli Silvius
Sent: Tuesday, May 07, 2019 11:42 PM
To: onap-discuss@...
Subject: [onap-discuss] #coe

 

Hi,

Building Multicloud-k8s-plugin on master fails.

Install Go 1.11
cd $GOPATH/src && git clone https://git.onap.org/multicloud/k8s
cd k8s/src/k8splugin
make build
...

go: downloading k8s.io/client-go v2.0.0-alpha.0.0.20181126152608-d082d5923d3c+incompatible

go: downloading go.etcd.io/etcd v3.3.12+incompatible

go: downloading github.com/hashicorp/consul v1.4.0

downloaded: h1:+gASq5lVUhelbDuyHr/ojUKGLZVeUhAFKHbAK8Kymfs=

go.sum:     h1:QOMBR2qlbwRbUJbJDXFjS8YEiXQc3AJBcEac7z3769I=

go: downloading k8s.io/client-go v2.0.0-alpha.0.0.20181126152608-d082d5923d3c+incompatible

go: downloading go.etcd.io/etcd v3.3.12+incompatible

go: downloading github.com/hashicorp/consul v1.4.0

go: finding golang.org/x/crypto/pbkdf2 latest

downloaded: h1:+gASq5lVUhelbDuyHr/ojUKGLZVeUhAFKHbAK8Kymfs=

go.sum:     h1:QOMBR2qlbwRbUJbJDXFjS8YEiXQc3AJBcEac7z3769I=

go: downloading k8s.io/helm v2.12.2+incompatible

go: downloading k8s.io/client-go v2.0.0-alpha.0.0.20181126152608-d082d5923d3c+incompatible

go: downloading github.com/hashicorp/consul v1.4.0

go: downloading go.etcd.io/etcd v3.3.12+incompatible

go: verifying k8s.io/helm@...+incompatible: checksum mismatch

downloaded: h1:vtddbkiGNMOd8maDDZDc111Rm9E5JeeNWDndows18i8=

go.sum:     h1:xSDfcFN8X6lfMKWQB1GmU18pnzIthU+/c7kkcl8Xlb0=

go: downloading k8s.io/client-go v2.0.0-alpha.0.0.20181126152608-d082d5923d3c+incompatible

go: downloading go.etcd.io/etcd v3.3.12+incompatible

go: downloading github.com/hashicorp/consul v1.4.0

downloaded: h1:+gASq5lVUhelbDuyHr/ojUKGLZVeUhAFKHbAK8Kymfs=

go.sum:     h1:QOMBR2qlbwRbUJbJDXFjS8YEiXQc3AJBcEac7z3769I=

go: downloading k8s.io/client-go v2.0.0-alpha.0.0.20181126152608-d082d5923d3c+incompatible

go: downloading go.etcd.io/etcd v3.3.12+incompatible

go: downloading github.com/hashicorp/consul v1.4.0

downloaded: h1:+gASq5lVUhelbDuyHr/ojUKGLZVeUhAFKHbAK8Kymfs=

go.sum:     h1:QOMBR2qlbwRbUJbJDXFjS8YEiXQc3AJBcEac7z3769I=

Makefile:31: recipe for target 'test' failed

make: *** [test] Error 1

Any idea what causes this and how to fix?


Br
-Samuli