Topics

#oom #aaf AAF Pods not coming up #oom #aaf

Gopigiri, Sirisha
 

Hi All,

I am trying to install ONAP Master using OOM(I am doing a redeploy. first did helm undepoy and then removed the /docker-nfs folder and then did a helm deploy). I could see the aaf-service pod is failing to start as it is unable to connect to cassandra I believe. Here are the log:

2019-06-06 12:12:50,333 WARN [init] 2019-06-06T12:12:50.333+0000 INIT [init] Cassandra is using Default Policy, which is not DC aware
2019-06-06 12:12:50,602 WARN [init] 2019-06-06T12:12:50.602+0000 INIT [init] Instantiating DAOs
com.datastax.driver.core.exceptions.NoHostAvailableException: All host(s) tried for query failed (tried: localhost/127.0.0.1:9042 (com.datastax.driver.core.exceptions.TransportException: [localhost/127.0.0.1:9042] Cannot connect))
    at com.datastax.driver.core.ControlConnection.reconnectInternal(ControlConnection.java:268)
    at com.datastax.driver.core.ControlConnection.connect(ControlConnection.java:107)
    at com.datastax.driver.core.Cluster$Manager.negotiateProtocolVersionAndConnect(Cluster.java:1652)
    at com.datastax.driver.core.Cluster$Manager.init(Cluster.java:1571)
    at com.datastax.driver.core.Cluster.init(Cluster.java:208)
    at com.datastax.driver.core.Cluster.connectAsync(Cluster.java:376)
    at com.datastax.driver.core.Cluster.connect(Cluster.java:332)
    at org.onap.aaf.auth.dao.AbsCassDAO.getSession(AbsCassDAO.java:434)
    at org.onap.aaf.auth.dao.AbsCassDAO.getSession(AbsCassDAO.java:394)
    at org.onap.aaf.auth.dao.cass.CacheInfoDAO.init(CacheInfoDAO.java:333)
    at org.onap.aaf.auth.dao.cass.CacheInfoDAO.<init>(CacheInfoDAO.java:83)
    at org.onap.aaf.auth.dao.hl.Question.<init>(Question.java:152)
    at org.onap.aaf.auth.service.AAF_Service.<init>(AAF_Service.java:99)
    at org.onap.aaf.auth.service.AAF_Service.main(AAF_Service.java:229)

Am I missing any configuration?

Thank you in advance!

Regards
Sirisha Gopigiri