Topics

#elalto #install #pmmapper PM Mapper Deployment issue #install #elalto #pmmapper


getme1986@...
 

Hi ONAP team,

while installing PM Mapper in elalto on kubernetes cluster into "dev-dcaegen2-dcae-bootstrap" POD which is specify into below link 

https://wiki.onap.org/pages/viewpage.action?pageId=60891174

While executing below command
" cfy install --blueprint-id pm-mapper --deployment-id pm-mapper -i inputs.yaml /blueprints/k8s-pm-mapper.yaml"
Uploading blueprint /blueprints/k8s-pm-mapper.yaml...
 k8s-pm-mapper.yaml |##################################################| 100.0%
An error occurred on the server: 409: <Blueprint id=`pm-mapper` tenant=`default_tenant`> already exists on <Tenant name=`default_tenant`> or with global visibility"

we need help to understand and resolve this error to proceed with ONAP installation for PM use case.


Regards
Sofi


getme1986@...
 

Hi ONAP team,

Could you please help on this .


Thanks,
Sofi


Vijay VK
 

HI,

The error is due to blueprint-id already existing in your setup.  You can either use new blueprint-id or delete the existing blueprint-id before running that command.

 

To delete –

cfy blueprint delete <blueprintId>

 

regards,

Vijay

 

From: onap-discuss@... <onap-discuss@...> On Behalf Of getme1986@...
Sent: Friday, March 20, 2020 3:19 AM
To: getme1986@...; onap-discuss@...
Subject: Re: [onap-discuss] #elalto #install #pmmapper PM Mapper Deployment issue

 

Hi ONAP team,

Could you please help on this .


Thanks,
Sofi


getme1986@...
 

Thank you Vijay for your inputs,

we retry same command ,after deleting  pm mapper blueprintId, we are getting below error.
============================================================================
[root@dev-dcaegen2-dcae-bootstrap-74ffcb56f4-dbjtv /]# cfy install --blueprint-id pm-mapper --deployment-id pm-mapper -i inputs.yaml blueprints/k8s-pm-mapper.yaml
Uploading blueprint blueprints/k8s-pm-mapper.yaml...
 k8s-pm-mapper.yaml |##################################################| 100.0%
Blueprint uploaded. The blueprint's id is pm-mapper
Creating new deployment from blueprint pm-mapper...
Unable to create deployment. Not all deployment plugins are installed on the Manager.
* Use 'cfy plugins upload' to upload the missing plugins to the Manager, or use 'cfy deployments create' with the '--skip-plugins-validation' flag  to skip this validation.
400: Required plugin k8splugin, version 1.7.2 is not installed on the manager
=========================================================================================================================

And we also retry  below command
'cfy deployments create' with the '--skip-plugins-validation, getting same error message .


Could you please help on this .


Thanks,
Sofi