Topics

[ONAP] Consul health check error while setting up ONAP R5

タパマガルサントス
 

Hi all,

 

We are now setting up ONAP R5 (El Alto).

In this process, there were following Consul health check errors.

Please confirm the attachment for detailed consul health check errors.

Has anyone encountered the same errors ?

We were unable to find bug information for R5 in jira.

We as ONAP users, would be very thankful if we can get some workarounds to solve the problems, can't we?

Or we can just ignore the Consul health check errors?

 

Best Regards,

 

Brian Freeman
 

Can you run :

 

kubectl -n onap get pod

and

./ete-k8s.sh onap health

 

We dont routinely use consul GUI but rather use the robot health checks to test.

 

Looks like many pods may not be in a running state so that could be for many reasons in your environment.

 

Brian

 

 

From: onap-discuss@... <onap-discuss@...> On Behalf Of ?????????
Sent: Friday, December 06, 2019 3:26 AM
To: onap-discuss@...
Subject: [onap-discuss] [ONAP] Consul health check error while setting up ONAP R5

 

Hi all,

 

We are now setting up ONAP R5 (El Alto).

In this process, there were following Consul health check errors.

Please confirm the attachment for detailed consul health check errors.

Has anyone encountered the same errors ?

We were unable to find bug information for R5 in jira.

We as ONAP users, would be very thankful if we can get some workarounds to solve the problems, can't we?

Or we can just ignore the Consul health check errors?

 

Best Regards,

 

タパマガルサントス
 

Hi Brain,

 

Thank you very much for the quick reply.

 

Running ./ete-k8s.sh onap health in our lab environment passed all 61 critical tests.

 

However the consul gui has some failing states as listed in the screenshot attached before.

 

Santosh

 

From: onap-discuss@... [mailto:onap-discuss@...] On Behalf Of Brian Freeman
Sent: Wednesday, January 15, 2020 10:48 PM
To: onap-discuss@...; santosu.tapamagaru.ev@...
Subject: Re: [onap-discuss] [ONAP] Consul health check error while setting up ONAP R5

 

Can you run :

 

kubectl -n onap get pod

and

./ete-k8s.sh onap health

 

We dont routinely use consul GUI but rather use the robot health checks to test.

 

Looks like many pods may not be in a running state so that could be for many reasons in your environment.

 

Brian

 

 

From: onap-discuss@... <onap-discuss@...> On Behalf Of ?????????
Sent: Friday, December 06, 2019 3:26 AM
To: onap-discuss@...
Subject: [onap-discuss] [ONAP] Consul health check error while setting up ONAP R5

 

Hi all,

 

We are now setting up ONAP R5 (El Alto).

In this process, there were following Consul health check errors.

Please confirm the attachment for detailed consul health check errors.

Has anyone encountered the same errors ?

We were unable to find bug information for R5 in jira.

We as ONAP users, would be very thankful if we can get some workarounds to solve the problems, can't we?

Or we can just ignore the Consul health check errors?

 

Best Regards,

 

Morgan Richomme
 

Hi

I sent a mail some weeks ago on consul status 
https://www.mail-archive.com/onap-discuss@.../msg17830.html

As far as I understand, It is not really maintained. It is still used by DCAE but lots of the failing tests are just due to the fact that these tests have not been updated and maintained. Some cleaning would be needed

Morgan



-------- Message d'origine --------
De : タパマガルサントス <santosu.tapamagaru.ev@...>
Date : 16/01/2020 09:34 (GMT+01:00)
À : onap-discuss@..., bf1936@...
Objet : Re: [onap-discuss] [ONAP] Consul health check error while setting up ONAP R5

Hi Brain,

 

Thank you very much for the quick reply.

 

Running ./ete-k8s.sh onap health in our lab environment passed all 61 critical tests.

 

However the consul gui has some failing states as listed in the screenshot attached before.

 

Santosh

 

From: onap-discuss@... [mailto:onap-discuss@...] On Behalf Of Brian Freeman
Sent: Wednesday, January 15, 2020 10:48 PM
To: onap-discuss@...; santosu.tapamagaru.ev@...
Subject: Re: [onap-discuss] [ONAP] Consul health check error while setting up ONAP R5

 

Can you run :

 

kubectl -n onap get pod

and

./ete-k8s.sh onap health

 

We dont routinely use consul GUI but rather use the robot health checks to test.

 

Looks like many pods may not be in a running state so that could be for many reasons in your environment.

 

Brian

 

 

From: onap-discuss@... <onap-discuss@...> On Behalf Of ?????????
Sent: Friday, December 06, 2019 3:26 AM
To: onap-discuss@...
Subject: [onap-discuss] [ONAP] Consul health check error while setting up ONAP R5

 

Hi all,

 

We are now setting up ONAP R5 (El Alto).

In this process, there were following Consul health check errors.

Please confirm the attachment for detailed consul health check errors.

Has anyone encountered the same errors ?

We were unable to find bug information for R5 in jira.

We as ONAP users, would be very thankful if we can get some workarounds to solve the problems, can't we?

Or we can just ignore the Consul health check errors?

 

Best Regards,

 

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.