SDNC POD not coming up


Sandeep Shah2
 

Hi Dan/Herbert -

I tried to install the latest SDNC images using the latest HELM charts, and unfortunately, SDNC POD not coming up...

I would appreciate any advice...Specifically, please see below (and also attached are detailed logs):

root@onap-nfs:~# kubectl describe pod -n onap dev-sdnc-0

lerations:     node.kubernetes.io/not-ready:NoExecute for 300s
                 node.kubernetes.io/unreachable:NoExecute for 300s
Events:
  Type     Reason            Age                   From                 Message
  ----     ------            ----                  ----                 -------
  Warning  FailedScheduling  27m (x3 over 27m)     default-scheduler    pod has unbound immediate PersistentVolumeClaims (repeated 4 times)
  Normal   Scheduled         27m                   default-scheduler    Successfully assigned onap/dev-sdnc-0 to onap-k8s-4
  Warning  FailedMount       5m24s (x10 over 25m)  kubelet, onap-k8s-4  Unable to mount volumes for pod "dev-sdnc-0_onap(ef52295c-012c-11eb-8772-fa163edb0d3c)": timeout expired waiting for volumes to attach or mount for pod "onap"/"dev-sdnc-0". list of unmounted volumes=[certservice-tls-volume]. list of unattached volumes=[dev-sdnc-data localtime logs data-filebeat filebeat-conf sdnc-logging-cfg-config bin config-input properties certs certservice-tls-volume dev-sdnc-aaf-config aaf-agent-certs aaf-add-config default-token-kz97k]
  Warning  FailedMount       64s (x21 over 27m)    kubelet, onap-k8s-4  MountVolume.SetUp failed for volume "certservice-tls-volume" : secrets "oom-cert-service-client-tls-secret" not found
root@onap-nfs:~# kubectl get pods -n onap -o wide | g


Thanks!

SIncerely,
Sandeep


alexander.dehn@...
 

Hi Sandeep,

 

Deployment is stuck on dev-sdnc-sdnrdb-init-job, which relays on dev-sdnrdb pods

 

can you send

kubectl get pods -n onap|grep sdnrdb

 

and

 

kubectl logs dev-sdnrdb-coordinating-only-xxxxx-xxxx

 

Thx, Alex

 

Von: onap-sdnc@... <onap-sdnc@...> Im Auftrag von Sandeep Shah2
Gesendet: Montag, 28. September 2020 04:25
An: onap-sdnc <onap-sdnc@...>; TIMONEY, DAN <dt5972@...>; Herbert Eiselt <herbert.eiselt@...>
Betreff: [onap-sdnc] SDNC POD not coming up

 

Hi Dan/Herbert -

 

I tried to install the latest SDNC images using the latest HELM charts, and unfortunately, SDNC POD not coming up...

 

I would appreciate any advice...Specifically, please see below (and also attached are detailed logs):

 

root@onap-nfs:~# kubectl describe pod -n onap dev-sdnc-0

 

lerations:     node.kubernetes.io/not-ready:NoExecute for 300s
                 node.kubernetes.io/unreachable:NoExecute for 300s
Events:
  Type     Reason            Age                   From                 Message
  ----     ------            ----                  ----                 -------
  Warning  FailedScheduling  27m (x3 over 27m)     default-scheduler    pod has unbound immediate PersistentVolumeClaims (repeated 4 times)
  Normal   Scheduled         27m                   default-scheduler    Successfully assigned onap/dev-sdnc-0 to onap-k8s-4
  Warning  FailedMount       5m24s (x10 over 25m)  kubelet, onap-k8s-4  Unable to mount volumes for pod "dev-sdnc-0_onap(ef52295c-012c-11eb-8772-fa163edb0d3c)": timeout expired waiting for volumes to attach or mount for pod "onap"/"dev-sdnc-0". list of unmounted volumes=[certservice-tls-volume]. list of unattached volumes=[dev-sdnc-data localtime logs data-filebeat filebeat-conf sdnc-logging-cfg-config bin config-input properties certs certservice-tls-volume dev-sdnc-aaf-config aaf-agent-certs aaf-add-config default-token-kz97k]
  Warning  FailedMount       64s (x21 over 27m)    kubelet, onap-k8s-4  MountVolume.SetUp failed for volume "certservice-tls-volume" : secrets "oom-cert-service-client-tls-secret" not found
root@onap-nfs:~# kubectl get pods -n onap -o wide | g

 

Thanks!

 

SIncerely,

Sandeep


Sandeep Shah2
 

Hi Alex - Here you go...please see attached log file...

If you need anything else, please let me know...

kubectl get pods -n onap|grep sdnrdb
kubectl logs dev-sdnrdb-coordinating-only-997f49447-lpgnc
kubectl describe pod dev-sdnrdb-coordinating-only-997f49447-lpgnc -n onap

Thanks!

Sandeep

On Mon, Sep 28, 2020 at 3:39 AM Alexander Dehn <alexander.dehn@...> wrote:

Hi Sandeep,

 

Deployment is stuck on dev-sdnc-sdnrdb-init-job, which relays on dev-sdnrdb pods

 

can you send

kubectl get pods -n onap|grep sdnrdb

 

and

 

kubectl logs dev-sdnrdb-coordinating-only-xxxxx-xxxx

 

Thx, Alex

 

Von: onap-sdnc@... <onap-sdnc@...> Im Auftrag von Sandeep Shah2
Gesendet: Montag, 28. September 2020 04:25
An: onap-sdnc <onap-sdnc@...>; TIMONEY, DAN <dt5972@...>; Herbert Eiselt <herbert.eiselt@...>
Betreff: [onap-sdnc] SDNC POD not coming up

 

Hi Dan/Herbert -

 

I tried to install the latest SDNC images using the latest HELM charts, and unfortunately, SDNC POD not coming up...

 

I would appreciate any advice...Specifically, please see below (and also attached are detailed logs):

 

root@onap-nfs:~# kubectl describe pod -n onap dev-sdnc-0

 

lerations:     node.kubernetes.io/not-ready:NoExecute for 300s
                 node.kubernetes.io/unreachable:NoExecute for 300s
Events:
  Type     Reason            Age                   From                 Message
  ----     ------            ----                  ----                 -------
  Warning  FailedScheduling  27m (x3 over 27m)     default-scheduler    pod has unbound immediate PersistentVolumeClaims (repeated 4 times)
  Normal   Scheduled         27m                   default-scheduler    Successfully assigned onap/dev-sdnc-0 to onap-k8s-4
  Warning  FailedMount       5m24s (x10 over 25m)  kubelet, onap-k8s-4  Unable to mount volumes for pod "dev-sdnc-0_onap(ef52295c-012c-11eb-8772-fa163edb0d3c)": timeout expired waiting for volumes to attach or mount for pod "onap"/"dev-sdnc-0". list of unmounted volumes=[certservice-tls-volume]. list of unattached volumes=[dev-sdnc-data localtime logs data-filebeat filebeat-conf sdnc-logging-cfg-config bin config-input properties certs certservice-tls-volume dev-sdnc-aaf-config aaf-agent-certs aaf-add-config default-token-kz97k]
  Warning  FailedMount       64s (x21 over 27m)    kubelet, onap-k8s-4  MountVolume.SetUp failed for volume "certservice-tls-volume" : secrets "oom-cert-service-client-tls-secret" not found
root@onap-nfs:~# kubectl get pods -n onap -o wide | g

 

Thanks!

 

SIncerely,

Sandeep


alexander.dehn@...
 

in oom master now the guilin images are used.
For an initial installation, we need a new elastic db version, which is not yet in oom. This is a task on my side.
as a workaround add in your override values.yaml within SDNC section:
sdnc:
  enabled: true
  elasticsearch:
    image: bitnami/elasticsearch:7.6.1-debian-10-r26
    master:
      image: bitnami/elasticsearch:7.6.1-debian-10-r26

Another issue, what I can see from the logs:
sdnc needs oom-cert-service which requires ejbca
therefore you need enable in override values.yaml
platform:
  enabled: true

I hope, that helps



alexander.dehn@...
 


Sandeep Shah2
 

THANKS Alex! I shall try...


On Mon, Sep 28, 2020 at 8:40 AM <alexander.dehn@...> wrote:
in oom master now the guilin images are used.
For an initial installation, we need a new elastic db version, which is not yet in oom. This is a task on my side.
as a workaround add in your override values.yaml within SDNC section:
sdnc:
  enabled: true
  elasticsearch:
    image: bitnami/elasticsearch:7.6.1-debian-10-r26
    master:
      image: bitnami/elasticsearch:7.6.1-debian-10-r26

Another issue, what I can see from the logs:
sdnc needs oom-cert-service which requires ejbca
therefore you need enable in override values.yaml
platform:
  enabled: true

I hope, that helps



Sandeep Shah2
 

Hi Alex - I would appreciate if you please comment on below....what I need to do exactly in HELM chart values.yaml? Thanks

Another issue, what I can see from the logs:
sdnc needs oom-cert-service which requires ejbca
therefore you need enable in override values.yaml
platform:
  enabled: true

I hope, that helps


On Mon, Sep 28, 2020 at 11:13 AM Sandeep Shah2 via lists.onap.org <sandeeplinux1068=gmail.com@...> wrote:
THANKS Alex! I shall try...

On Mon, Sep 28, 2020 at 8:40 AM <alexander.dehn@...> wrote:
in oom master now the guilin images are used.
For an initial installation, we need a new elastic db version, which is not yet in oom. This is a task on my side.
as a workaround add in your override values.yaml within SDNC section:
sdnc:
  enabled: true
  elasticsearch:
    image: bitnami/elasticsearch:7.6.1-debian-10-r26
    master:
      image: bitnami/elasticsearch:7.6.1-debian-10-r26

Another issue, what I can see from the logs:
sdnc needs oom-cert-service which requires ejbca
therefore you need enable in override values.yaml
platform:
  enabled: true

I hope, that helps