Openo TOSCA Model Designer docker container not working



I tried and installed the latest docker instance of TOSCA model designer, but the model designer is not displayed on openo UI. (shows blank white page when tried in multiple browsers) . As part of debugging, I found in docker logs that  it is  pointing to wrong MSB address ( Despite the fact that MSB_ADDR environment variable has been correctly provided, it hits the REST calls incorrectly as shown below.

13:42:04.133 [localhost-startStop-1] DEBUG org.eclipse.winery.repository.Prefs:143 doRepositoryInitialization - There seems to be no git repository at the specified location. We fall back to the file-based repository
13:42:04.134 [localhost-startStop-1] INFO  javax.servlet.ServletContextListener:42 contextInitialized - ******* context init***********
13:42:04.136 [Thread-1] DEBUG org.eclipse.winery.repository.Prefs:216 run - Initializing XML validation
13:42:04.138 [localhost-startStop-1] INFO  o.e.w.common.config.ServiceRegistrer:151 getConfigFilePath -  class path:/service/modeldesigner/.extract/webapps/modeldesigner/WEB-INF/classes/
13:42:04.139 [localhost-startStop-1] INFO  o.e.w.common.config.ServiceRegistrer:153 getConfigFilePath - config file path:/service/modeldesigner/.extract/webapps/modeldesigner/WEB-INF/classes/../../../../../conf/winery.yml
13:42:04.304 [localhost-startStop-1] INFO  o.e.w.common.config.ServiceRegistrer:127 readConfigFile - config file detail:org.eclipse.winery.common.config.externalservice.entity.MsbConfig@1ed86d31
13:42:04.307 [register modelDesigner service to Microservice Bus] INFO  o.e.w.common.config.ServiceRegistrer:64 run - start modeldesigner microservice register
13:42:04.410 [Thread-1] DEBUG org.eclipse.winery.repository.Prefs:219 run - Initialized XML validation
13:42:04.565 [register modelDesigner service to Microservice Bus] INFO  o.e.w.common.config.ServiceRegistrer:72 run - start/winery  microservice register.retry:0
13:42:04.701 [register modelDesigner service to Microservice Bus] INFO  o.e.w.c.c.e.msb.HttpClientUtil:61 post - apiURlhttp:// parameters:{"serviceName":"/winery","url":"/winery","protocol":"REST","visualRange":"1","nodes":[{"port":"8202","ttl":0}]}

On further debugging, I found out that  MSB address present in /service/modeldesigner/conf/winery.yml is incorrect. Please check if my observations are correct and suggest how to go ahead.